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I. Introduction:

SPAMALIZE can read, analyze, and write medical image files. It is  menu-driven, requiring little if any command-line interaction. SPAMALIZE was originally designed to analyze PET and MRI data, but has

evolved into a GUI-driven environment versatile enough for many imaging formats. 

A. Encouragement and Disclaimers

If you use SPAMALIZE and find it helpful, please let the author know! SPAMALIZE can be used free of charge by academic users. However, bearing in mind that there is no such thing as a free lunch, please consider including the author of SPAMALIZE on the first published paper, abstract, etc. which uses SPAMALIZE to perform a significant portion of the data analysis. The criteria is that if you would have found it difficult or tedious to write the program that performed an important part of your analysis, you should think about sharing the credit. (You would not believe the number of people that forget about this requirement as they rush a paper off to press!) If you forget to include me as a coauthor, other gestures of gratitude are appropriate, such as buying me a beer at the next conference we attend. 

DISCLAIMER: I enjoy hearing feedback, and would be happy to modify SPAMALIZE routines for individuals with interesting applications. However, expect no support unless you have made arrangements with me. You are urged to contact me prior to using SPAMALIZE. Programs are updated and added on an ongoing basis, and certain programs may be "under construction" or unsuitable for specific applications. SPAMALIZE is updated as bugs are reported or as needs develop. 

You may use SPAMALIZE only if you (or a representative of your organization) have received permission from the author, Terry Oakes. The author takes no responsibility for the results. It is the responsibility of each user to check  the code, the input data, and the results for appropriateness. In particular, do not use SPAMALIZE to analyze data critical for human subject diagnosis or care.

B. File formats supported 

Formats which have been used successfully include:


PET (CTI/ECAT 933, CTI/ECAT 953B, GE/Advance, microPET)


ANALYZE-formatted images (e.g. from AIR, SPM, etc.)


MRI (GE/Signa)


Raw, a.k.a. flat a.k.a unformatted


FMRI


LORETA


CT


DICOM


TIFF (for autoradiographical images)


VoxBo

The EZ-Writer suite of read/write programs supports most file I/O. Code for other formats may be added as needed. Images from several different files and/or formats may be used simultaneously by various specialized routines, which create additional arrays to store the images. This ability is limited only by the amount of memory (RAM) available and the size of the data set.

II. Installation Instructions:
A. Download:

Send an email to Terry Oakes (troakes – at – wisc.edu) to receive download instructions. Please include your name, institution, and a brief (1-2 sentence) description of your project. Once you have the instructions, use a web-browser go to the website:

http://tezpur.keck.waisman.wisc.edu/~oakes/download/

B. IDL Virtual Machine (free) Installation of Spamalize:

If you download the file "spam_VM.tar.gz", you can use a free version of IDL to run Spamalize. You first need to download and install the IDL Virtual Machine from http://www.rsinc.com

At the download site, click on the file "spam_VM.tar.gz" to download it. 

I suggest making a new directory 

/.../RSI/spam_vm/ and putting it there, 

in a subdirectory of where IDL is installed.

Then unzip and untar the file:

- gunzip spam_VM.tar.gz

- tar -xvf spam_VM.tar

(Depending on your computer's settings, these last two steps may happen automatically.)

Under IDL 6.1 and later, the current working directory is where the file "spam_VM.sav" is located that you invoke from the VM. Thus, the .sav file must be in the same directory as the "spamalize_defaults.txt" file, and the “data/” and “help/”directories must be subdirectories of the current working directory.

Make sure this is so after you finish un-tarring the files. Also make sure the file "spamalize_defaults.txt" is in this directory. Finally, create a temporary directory at this level, called “temp”.

After this, you only need to edit a single file to use Spamalize. Using a  text-editor, open the file

   /spam_dir/install/spamalize_defaults.txt

and follow the instructions there.

Calling/Use:

The "tar" file was made with the help files sourced from ./src/help/, so (depending on how your tar-file gets extracted) you may need to move the help directory up one level so the help directory is in the same directory as the VM file "spamalize_rt_vm.sav".

To call this program, under unix/linux or similar, type:

idl_6.1 -vm='/apps/dev/spamalize/spamalize_rt_vm.sav'

Under Windows/Mac, drag the file icon onto the IDL/VM icon.

Limitations of VM:

 1) Can't use EXECUTE procedure:

  Several (~20) Spamalize programs use the EXECUTE procedure, mostly to reinterpret strings containing variable information. This is not allowed in IDL-VM, since this would provide a sneaky backdoor to let VM users have "full" IDL. The programs or subroutines that use EXECUTE will crash when you try to use them. Most of the instances of EXECUTE in Spamalize are in fairly minor programs or little-used situations. Please let me know if your favorite program doesn't work under the VM version- we can probably fix it.

Please read the first section of this document, “Encouragement and Disclaimers”. After that, you can get to work! 

C. Installation Instructions (IDL Full license):

Download (e.g. ftp) a tar-ball file of SPAMALIZE onto your local disk system, maintaining the directory structure. Un-tar the files. The top-level SPAMALIZE directory is called (not coincidentally) "spamalize". Recommended (standard) locations for the spamalize directory are:


unix/linux: 
/apps/


Windows:
C:\RSI\

The disk where you put the spamalize temporary directory should be large enough to contain any image files that might get written there, and should have its write-permissions set so that anybody who uses SPAMALIZE can write to it. Otherwise, a crash will most likely result.

Make sure that the directory

   /spam_dir/install/

is in the IDL path. In the IDLDE GUI, select "File->Preferences...", then select the "Path" tab, and "Add" the /.../spamalize/ directory to the path. Check the box to the left of the directory to include all subdirectories.

After this, you only need to edit a single file to install Spamalize. Using a  text-editor, open the file

   /spam_dir/install/spamalize_defaults.txt

and follow the instructions there.

And that's it! You are done with the installation. If you want to customize Spamalize or enhance its performance, some tips for power users and programmers follow, organized according to OS.

D. Calling Sequence (Full Installation):

1. Introduction:

There are several ways to call SPAMALIZE:

- The easiest way is to add the SPAMALIZE directory to your IDL file path via the Preferences menu in the IDLDE (GUI) environment. After you add the directory "/.../spam_dir/", click the box to the left of the directory name, to include the subdirectories.

- If you want to call SPAMALIZE as the IDL startup file, select 

  "/.../spam_dir/src/spamalize_startup.pro" 

from the Preferences menu. This is only a good idea if the only IDL application you will use is SPAMALIZE. Do NOT do this at the LfAN.

- If you want to compile and run SPAMALIZE from within the IDLDE environment, open, compile, and run the file "/.../spam_dir/src/spamalize.pro'.

- If you are currently in the SPAMALIZE main directory, you can enter IDL and  type "SPAMALIZE".

The primary SPAMALIZE code is contained in /.../spam_dir/ (unix), which is the same as W:\local\progs\spamalize\ (Windows/PC). All Unix machines and Windows95/PCs machines should reference this. Every attempt is made to ensure that the code used by the Unix machines is identical to and compatible with the PC version, primarily by having then run the IDENTICAL CODE.

2. Unix:

Call from the shell script "spam__unix", containing the command:


idl /local/progs/spamalize/src/spamalize_startup

The file "spamalize_startup.pro" is technically not a procedure, but rather a "main" program, which is analogous to a batch-file. This construct is the only way to call idl from the command line and start up a series of programs. It is a short program, which does the following:


spam_dir = '/local/progs/spamalize/src/'


if (!VERSION.OS_FAMILY EQ 'unix') then !PATH = !PATH+ ':' +spam_dir


SPAMALIZE

the last line calls the actual program (SPAMALIZE.PRO). This command can be an alias in your .cshrc file:


alias spam '/local/progs/spamalize/src/spam__unix'

It is tricky to set SPAMALIZE as the default when starting IDL; calling SPAMALIZE as the IDL startup is not usually a good idea, since sometimes you will want to call IDL without SPAMALIZE.

3. Windows95/98/2000 (also Windows NT, Linux emulator):

Run IDLDE (the interactive version with the fancy menu). This is usually located in 

  C:\RSI\IDL52\IDLDE

Go to File->Preferences->Path. Add the directory:


W:\local\progs\spamalize\

Click the box to indicate you want to search all subdirectories.

If you want to have SPAMALIZE start automatically when you start up IDL:

Go to File->Preferences->Startup. Add the following:


IDL Main Directory:
C:\RSI\IDL52


Startup file:

W:\local\progs\spamalize\src\spamalize.pro


4. Macintosh:

Follow general scheme for unix for the settings in “spamalzie_defaults.txt”, but follow the Windows guidelines for starting IDL and Spamalize.

E. Installation patches, etc.

1) There is a bug in the IDL routine STR_MID prior to IDLv5.3, which you will  have to fix in your IDL distribution code. Change line 93:

    arr[count] = strmid(str, spos, strlen(str))  ;Last element

to:

    slen = strlen(str) & slen=slen[0]

    arr[count] = strmid(str, spos, slen)  ;Last element

Note that this frequently looks like a bug in STR_SEP.

III. Programming Hints (for Full Installation): 

A. Source Code.

The full download includes all of the Spamalize source code. You can read this code, and have permission to use entire programs and/or code snippets in your own programming efforts. Simple courtesy should apply here- you need to find a way to give credit to the Spamalize author. If you are unsure about how to do this, email Terry Oakes. Also, if you have specific questions about how to incorporate or use any of the Spamalize modules, send Terry an email.

B. File naming conventions:

Programs which are primarily for displaying images in windows, or which are primarily composed of widgets for a user interface, tend to be named "spw_***.pro", while programs whose primary purpose is to

perform a task with little user input tend to be named "spam_***.pro". Frequently there are pairs of similarly named programs: the "spw_" program gets input and parameters from the user, and the "spam_" program performs the desired task. This makes it easy to incorporate a worker program (spam_***) into a larger program without needing to use the GUI interface. 

See the file, "Catalogue_of_spam", for a brief description of individual programs and functions, as well as a more detailed explanation of how SPAMALIZE functions. Most individual programs have fairly detailed documentation within the source code. In particular, there is usually a one-line "Purpose", a longer "Abstract", a "Calling Sequence", and an explanation of parameters and keywords within each program.

At the Waisman lab, IDL/SPAMALIZE files are kept in the directory:

 /apps/spamalize/

which is called simply "/.../spam_dir/" in this document.

There are several subdirectories needed by SPAMALZIE:

 /.../spam_dir/install/

installation files, instructions.

 /.../spam_dir/src/

"spam_*.pro" and "spw_*.pro" source files.

 /.../spam_dir/src/aux_progs/
auxiliary SPAMALIZE routines.

 /.../spam_dir/src/ez/

EZ-Writer file read/write programs.

 /.../spam_dir/src/help/
help files used by SPAMALIZE.

 /.../spam_dir/src/obj/

IDL object-oriented programs.

 /.../spam_dir/src/voi/

VOI, ROI, related display programs.

 /.../spam_dir/data/

data files needed by SPAMALIZE.

 /.../spam_dir/temp/

directory where some output files get written. 

C. Data I/O.

In some older Spamalize programs (e.g. “Display”, “Write”, “Sum”), the data are read into a central location and are accessible to all older programs. Image data are stored in an array, "img_arr". Associated image subheader info is stored in the array "sub_header", and main_header info is stored in the array "main_header". These arrays are all COMMON arrays, declared from the main program (SPAMALIZE) so they are available to all subroutines that declare the appropriate COMMON variables. Any type of image array can be stored in img_arr. All quantitation should be performed by the I/O routines, so "img_arr" contains fully quantified values. SPAMALIZE sub-headers and main-header contain enough empty space so they may be modified if necessary to accommodate most types of images. This system got a bit unwieldy, so most newer programs (BrainMaker, BrainSqueezer, Patlak plots, etc.) are each reposnible for their own data I/O. Most programs use the same core of programs from the EZ_WRITER suite for file I/O.

D. Make a shortcut to call SPAMALIZE easily.

For a Full license:

alias spam 'idl /apps/spamalize/install/spamalize_startup'

(Change the directory name above to reflect your installation.)

Edit the following shell script and Spamalize program so that the directories reflect your directory structure.

/spam_dir/install/spamalize_startup.pro

Then, all you ned to do is type "spam" at the command line to start IDL with Spamalize. I recommend this approach, as opposed to making Spamalize be the default startup file, because if (heaven forebid!) you need to start IDL without Spamalize, you can then easily do so.

Run-Time IDL:

If you have a RunTime or VM license and the SPAMALIZE .sav file:

alias spam 'idl -rt=spam_dir/src/spamalize.sav'

E. Customizing Spamalize for your site:

Modify the following file, which contains directory shortcuts andgraphics-related parameters:

 /spam_dir/install/spamalize_defaults.txt

The "defaults" text file is used so that users can modify the defaults at their own site. This is especially useful for users with a Virtual Machine or RunTime license, because without a text-file containing the defaults, the defaults have to be "cast in stone" when the RunTime application is created.

Using the preferences file "/spam_dir/install/spamalize_defaults.txt" means that you can build up a set of preferred settings over time and not have to figure out what they were every time you upgrade your version of SPAMALIZE. It is helpful to save the preferences file elsewhere when you upgrade to a newer version of Spamalize, then copy the old settings into the new preferences file. (Do not copy over the old preferences file, in case new categories were added.)

For the full colorized glory of certain SPAMALIZE buttons and menus, you will need to add some IDL menu-related items to your ".Xdefaults" file for unix/linux OS (usually in your home directory).

Change the location of the temporary-file directory.

You need to make sure that the designated temporary directory for Spamalize is large enough that many large files can be written to it, and that all users have read- and write-permission for it. There is a somewhat complex Spamalize program that tries to make sure that output files can be successfully written. It tries several locations if the first does not work. If writing to any directory fails, Spamalize will eventually attempt to write the data to /spam_dir/temp/ so make sure this directory can also be written to by all users.

