
IV. BrainMaker Examples

IV.A. This section provides a step-by-step illustrated example of creating a VOI from scratch
using BrainMaker, including how to draw, edit, name, and save it.
1) Fire up BrainSpinner from SPAMALIZE’s mainmenu. Click on “Analysis”, and from the
pulldown menu select “BrainMaker (ROIs)”.

As subsequent menus appear, they will tend to obscure the mainmenu above. Try to position
your menus so you can see the lower left-hand corner of the mainmenu, as this is where
informative messages will appear, particularly if something goes South.
For an explanation of other features in the mainmenu, click on the “Help” button there, or refer
to the SPAMALIZE web-page at:
http://psyphz.psych.wisc.edu/~oakes/spam/spam_frames.htm
This example uses the image “nT1.img” in the SPAMALIZE data directory. If you use this as
well you should be able to follow the text and pictures exactly.



BrainSpinner’s small main menu will appear as follows:

The first thing to do before you can access any useful features is to load in a base image. This is
usually a MRI image, but can be any ANALYZE image that you want to examine or draw upon.
Click on the “Open” icon next to the “MRI File” box. This icon flashes “Pick Me!” when
BrainSpinner is started.

Before a base image is loaded, the only buttons you can use are “Color Table”, “Current Directory”,
“Quit”, and “Help”. If your base image file is not in the SPAMALIZE default data directory, you
will probably want to set the search directory by clicking “Current Directory” and then selecting
the nearest directory. At the LfAN, tell Terry if you want another directory included. Elsewhere,
ask your SPAMALIZE administrator to edit the file:

“/…/spamalize/data/spamalize_defaults_XXX.txt”
where XXX is unix, win95, mac, etc. The current directory list will be updated to reflect the five
(5) most recent directories from which you loaded a file, so you can easily switch between
commonly used directories.
Clicking on the “Open” icon causes a browse menu to appear. All of the “*.img” files in the
current directory will be listed. Double-click on the file you want. BrainMaker will suddenly
become very busy doing the following things:
- Opens MRI image file, reads it into an array in memory (“mri_img_arr”).
- Makes sure currently loaded PET and mask data, if any, match the new MRI file.
   The image dimensions (number of pixels) and pixel dimensions (mm) must be the same.
- Estimates a reasonable magnification factor.
- Displays the axial image.
- Creates the other displays (coronal, sagittal, adjunct) but does not make them visible.
- Enables all of the items in the main, icon, and parameters menu.
- Creates an empty working mask (in memory).
- Awaits your next move.



To see the coronal and sagittal views, click on their icons:

Now your screen should look something like this:

SPAMALIZE mainmenu axial view Icon Menu

BrainMaker main menu coronal view sagittal view Parameter Menu



BrainMaker is designed to have a lot of smaller menus and displays, so you can move them
around however you wish. This makes it convenient to use on various screen sizes. Also, if there
is one view (e.g. sagittal) that you use more than the others, you can make this view very large
and still refer to the other smaller axial and coronal images.

Let’s suppose we have a burning interest in the caudate, and we want to define a VOI
encompassing the right- and left-hand sides seperately. Let’s also suppose that the image we
loaded is stored in the radiological convention, i.e. the left side of the image is the subject’s
right-hand side.

Before starting to draw, examine the icon menu to see the status of your drawing tools. The
pencil icon is highlighted (has a dark frame), so you are in “edit/add” mode. You will add a
single pixel at a time, since the “small” cursor size is highlighted. The current view is sagittal,
since you just clicked on the sagittal icon.

Place the cursor over the right caudate (left-hand side of image), depress it once, and release.
Voila! A red box appears, outlining the ROI, which consists of a single voxel. At this point, you
have created the following:
1) axial mask: a 2D ROI mask.
2) coronal mask: a 2D ROI mask.
3) sagittal mask: a 2D ROI mask.
4) VOI working mask: a 3D VOI mask in memory, with one pixel set to 1, all others 0.



You can continue selecting single pixels one at a time, or you can depress the cursor and drag it
over the pixels you want to include in the ROI. For faster drawing, select the “Freehand draw”

icon. Then depress and
hold the left mouse button
over a pixel on the edge of
the caudate, and trace a
line around it. When you
are near your starting
point, release the mouse.
The ROI will close itself
automatically, joining the
starting and ending points.
Change the crosshair to
“Med” to better see the
current location.You now
should have something that
looks like the images to the
right.
Notice how the coronal
and sagittal images were
automatically updated to
show the ROI in those
views.

Quickest Draw in the West.
You can page through the axial views one at a time, drawing the caudate as before, but
eventually you are bound to think, “If I had a window in my office I bet it would look like a great
day to wander down to the Union! How can I get out of here sooner?” There are several
approaches to speeding things up:
1) Hire someone else to do it;
2) Try a connected pixel search;
3) Limit the tissue you include based on a histogram of the data.

Let’s assume you are reading this because your boss already thought of idea 1, so we will
proceed right along to idea 2. Go to the next (unedited) axial slice, and place your cursor in the
center of the caudate using the middle mouse button, so as not to edit/unedit anything.
Now press the “hounddog” icon:



You will get something like the picture on the left:

Much more tissue than just the caudate was selected. This is because the search criteria is too
leniant. Move the “Threshold” from 20 (the default) down to 3.
Click on the “Cut” icon to delete the mask from this
plane, then press the “hounddog” icon again. You
will get something like the picture above on the right.

This method works fairly well for structures which are well-defined and have crisp edges. As
you can see from the example above, the caudate still needs a little bit of editing, and it might
have been faster to simply draw the caudate by hand in the first place. However, notice how
good a job it did at defining the edges of the whole brain on the left!

After a little experience you will be able to quickly discern if a structure is well-defined enough
to beneifit from this approach. The nice thing about it is that it is fast and only requires one
button click.

Also, this connected-pixel search approach can be combined with the tissue-limited appraoch
(described next) and with the morphological operators (described in the Help manual under the
“Display Parameters” menu) to rapidly draw a ROI that is reasonable close, then clean up some
of the rough edges.



Let’s assume you want to finish by sundown, so you are willing to try a faster method yet. We
will now look at how to limit the tissue you include based on a histogram of the data. Click on
the “Segmentation” button in BrainMaker’s mainmenu. You should see the menu below. The
thresholds between the various tissues will be arbitrary, so have BrainMaker take a guess by
selecting “Set Histogram Thresholds -> Automatic”. The thresholds should appear similarly to the
picture below; if they do not, move the thresholds by hand until your thresholds are in the same
relative position as the picture. Notice how the histogram color-scale matches to the image color-
scale, so you can see what color corresponds e.g. to the CSF/GM threshold. (For detailed
instructions on all of the options in this menu, refer to the “Segmentation Menu” section of the
BrainMaker help manual.)

To have BrainMaker limit the ROIs you draw to contain only grey-matter (GM), unselect all of
the tissue boxes except “GM”, which are shown “checked” above. If you like, click on “Verify” to
make sure that the tissue type(s) you want are known to BrainMaker. Sometimes if you quickly
click and unclick a box several times in a row, BrainMaker gets confused…
Now, you can draw a big, messy (and quick!) ROI around the caudate, and all non-gray matter
will be automatically excluded. This is a prety fast way to “rough in” a VOI by hand.



By now you have drawn ROIs on all of the axial views of the caudate. The next step is to look at
the coronal and sagittal views to make sure you defined the edges accurately. Probably the edges
look rough in these other two views, and you want to clean them up a little. You can edit by
hand, or use “Mask Filter -> Fill” and “Mask Filter -> Open” from the “Display Parameters” menu.
Refer to the Help Manual section for this menu to get a complete explanation of how these work,
but suffice it to say that 1) you will definitely want to practice with these filters before you really
need them, and 2) they are extremely handy. When you are done you should have a cleaned-up
VOI that looks like the following:

Now let us suppose you are finished with the right caudate, and you want to start drawing on the
other side. NO NO NO! If you do that, it will be impossible to tell the right side from the left in
subsequent analysis sessions. First, you must SAVE the ROI you have just created. Click on
“Anatomy” in BrainMaker’s main menu. You should see the following menu:



Normally, you would create a new mask-file by selecting "ROI- File -> Create File". However,
if you are using the default “nT1.img” from SPAMALIZE’s data directory, you will over-write
the existing ROI (which has some useful structures drawn in it), so don’t actually do this now. If
you are starting with a fresh MRI file and have not yet created a mask-file for it, you would
proceed as follows:

1) Select "ROI- File -> Create File". The default naming convention is to add "_ROImask" to the
reference filename. For example, if you have a file named

W:\exp\morhip\MRI\sub123\E123.img
the ROI mask file would be named something like:

W:\exp\morhip\MRI\sub123\E123_ROImask.img
BrainMaker checks to see if a file with the currently selected name already exists, and gives you
the option to overwrite it (which you should only do if you are SURE you know what you are
doing) or else to create a new filename with a date/time stamp incorporated, e.g.:

W:\exp\morhip\MRI\sub123\E123_ROImask_20000413_112845.img
where the numgers show the year (2000), month (04), date (13), hour (11), minute (28), and
second (45).
If you follow this naming convention then subsequent searches and data processing will be
facilitated. You must have write-permission or the disk (folder) where you wish to store the new
mask-file. An ANALYZE file with the identical dimensions as the reference file (MRI) will be
created so there must be room on the disk, or else the write will fail.

2) Select a name for the masked region from the Anatomy menu.

To select a name, you must add an anatomic label to the list by clicking on “Add ROI to List”. A
pull-down menu will appear listing all of the anatomic VOI names that BrainMaker knows
about. Select one of these (in this case, “Caudate”) to add it to the visible list of potentially active
VOIs. Now, you may save a new ROI with this new anatomic structure’s name.

Select "R" (for “Right”) next to the “Caudate” label. Notice how the "R" label is on the left, to
remind you that the image data may be in radiological format.

You may only have a single structure selected for the next step, which is to save your working
VOI into the Group VOI.To unselect a structure, select the "None" button, or "Unselect All" to
unselect all structures, which is handy if you have a long list of structures that are not all visible
in the menu.

3) Store the working mask volume to the Group mask volume (in memory). Move the working
VOI into the Group VOI by selecting “ROI -Current -> Store ROI to Group”. This puts your
working VOI into the hierarchical structure of a BrainMaker VOI file.

4) Write the group mask volume to the mask-file. To permanently save your work, you must
write it to a file. First you must create a new ROI file, or load an existing one (reviewed
elsewhere). Selecting "ROI  -Group -> Save ROIs to File" will save your work. This will cause
the current contents of the reference ROI mask volume (in memory) to be written out to the file
named in the Anatomy menu. Note that this will overwrite the existing contents (if any) of this
file.You can avoid this by renaming the file in the Anatomy window.



To find out what the volume of the working mask is, click on “ROI stats” in BrainMaker’s
mainmenu. You should see the following menu, which is fully explained in the “ROI Stats”
section of the Help Manual. The name of the region (if known) and the volume are listed in cubic
centimeters (ml or cm3) in the upper panel.

A histogram of the VOI is shown at the bottom. If you leave this menu open, the volume displays
will be updated every time you edit the VOI. This will noticeably slow down your editing, so
you probably should keep this menu closed most of the time.

To draw the other (left) caudate, you must start with a clean slate. With the original (right)
caudate safely stored in both the Group mask volume and in the ROI mask file, you can erase or
blank the working mask volume with the “Refresh mask” icon:

Now, start drawing the left caudate just as you did the right caudate. The only difference is that
when you save the left caudate to the Group, you will select the “L” button. Also, you will not
have to create a new ROI mask file; simply save the left caudate to the same file as the right
caudate. BrainMaker will pop up a warning message asking you if you really want to save to this
file, but normally you can just respond “Yes”.

And there you have it- you drew the left and right caudate, saved them, and you can still catch
the sunset over the lake at the Union.
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